Unity is currently almost unusable

Hi all,
First off I’m running windows 10 64 bit.
I’m running Unity 5 64 bit with VS Community 2015.

I was doing a build for android when Unity complained that no valid JDK was detected. At the same time I experienced a number of other errors with Unity and I’m on the verge of needing to do a complete system wipe.

So my issues:

  • Scripts now open in Mono Develop not Visual Studios. I have confirmed that VS is still selected in preferences → external tools.
  • Failed to import package with error: Couldn’t decompress package. This now occurs with every single package(from the Unity store to Standard Assets)
  • Clicking links in Help like Unity Answers do not work.
  • Right clicking a folder in inspector and clicking on Show in Explorer no longer works.

Troubleshooting I’ve done :

  • I have tried multiple projects,including new projects.
  • I have tried using the hidden windows 10 admin account.
  • I have reinstalled Unity.
  • I have uninstalled, searched the registry and removed all Unity references, then reinstalled .
  • I have run registry cleaners also.
  • I checked in the Unity install folder and 7zip is present in the Tools folder.
  • I have run Unity as admin.
  • I have removed the Unit folder in programdata and relicensed.

Java aside, (I have reinstalled the JDK, confirmed it is recognised by running cmds javac -version etc,however still the android sdk and Unity do not recognise that the JDK is installed.) I cant use Unity to any great extent now and fear that Ill need to wipe and reinstall windows.

Everything else is fine on the pc, I have no other errors with any apps. I get the impression that this is something to do with windows possibly. My problems in Unity all seem to relate to using external programs, eg importing package using 7zip,opening scripts cant open VS etc.
Im tearing my hair out with this one. ANY help would be hugely appreciated.

To solve I had to reinstall windows. Unity and java seem fine now.Strange…