Unity Lockfile and Version Errors

I went to use Unity and all these errors come up like:

A version error that says it was created with 5.0 even though I used Unity 2020.3 LTS
A LockFile error

Please Help

thanks

Unity logs errors, warnings, and information related to version control. unlock files in Plastic SCM, you must edit a specific Plastic SCM lock file externally.,(Desktop) Fixed a deadlock that could cause the Unity Editor to freeze when disposing (Editor) Fixed spurious errors about missing google-services.json file‚Äč. TelltheBell Model file ( pom.xml ) references a specific version using a range expression.