Unity login loop

Hello, when I try to login on unity editor with my account it loops and keeps me asking for login.
I tried with other accounts and doesn’t happen. Just with this one.
Can anyone help me? thanks.

Same problem I also have. I am new here and in Unity technology in general, but I noticed that this problem repeats from 2015 or earlier :D, version after version (I google it). And honestly I am surprised that it is still present.

I am having the same issue… I am trying to download an assets package and when asked to login it just looped and asked for them again, no invalid credentials… Reset my password and it seems to have done nothing for it, is there any solutions for this?,I am having the same problem with my Unity Desktop app… tried to download an assets package and the login screen just loops… i know the login details are correct because i can login on the website, tried resetting password but no luck. Any solutions found for this yet?

I have the same problem. Can´t login with my account, nor with google login or facebook login.

Need access to download changes from Collab.

Same problem here, tried Unity 2017.4.0f1 and Unity 2017.4.1f1 with Unity ID, Google and Facebook.

Same issue here.

Fresh unity install on my machine and after reset my password the problem still persists.

Same issue too.
In the AppData\Local\Unity\Editor\Editor.log there is the following line when I try to login:

[CEF] Uncaught TypeError: Cannot read property 'addEventListener' of undefined in https://api.unity.com/v1/oauth2/authorize?cid=5925c555-6a8c-46d0-9428-6e30b59fe3a5005f&event=next

Same here. Seems to be only affecting my Google account.

Was planning on shipping an app literally today and now I can’t access any Unity Services.

Goodbye deadline.

I have a very very dirty workaround:

  • Download Unity Hub
  • Create new account
  • Run through the licence questionnaire
  • Once logged in, log out of the new account and log in to your old account
  • Voila! It should now let you login.

I got stuck in this loop for a while before trying a manual activation. I think it’s because you may be behind a firewall or proxy. This page explains: