Unity missing textures in some parts of model

Hi all.
I have been working all day to set texture to my 3d model in sketchup and then exported it as a .dae.
Now when I import the textures and then the .dae file all materials are there but the problem is that some materials does not work. They have the texture on them and all but its just gray instead of the texture.
Here is a screenshot of my scene.

As you can see is the selected mesh gray but it has a texture “tapet” as shown in the inspector. Does anyone know why this is? (I have also imported the file to blender and exported it in diffrent formats but still the same problem. In blender all textures are fine.)

If you are importing your model with the “two sided faces” option enabled in the SketchUp Importer it may be rendering your texture on the back face (or not rendering that face at all if this option is disabled), you can right click in SketchUp on faces and reverse face to see if this works. Also, to help with making sure faces are turned the right way, use monochrome view in SketchUp before you export, this show back faces as light blue and front faces as grey, make sure all faces are gray unless rendering both sides of faces.

Hope this helps.