Unity Monodevelop problem: cannot type ' or " quotation mark

Hi all,

As I have downloaded the new Unity 3.4 it also installed a new build of the monodevelop editor. The problem is that from now on, I cannot type a single or double quotation mark anymore. So the ’ and " symbol are not typed when I press on the button on my keyboard. This is quite annoying to say the least.

I have been checking around and other text editors don’t seem to have the problem. I also downloaded the normal 2.4 release of Monodevelop and this one seems to do things right. Also when I switch keyboard layout to azerty - Belgian I can type the quotation marks too.

I am working on MacBook Pro OSX Snow Leopard which has an azerty (Belgian) keyboard. But for coding I use an external US international keyboard. The problem occurs when I am using the US international keyboard setting.

Can someone tell me how to solve this problem or can anyone give me a link to a previous version of the Unity Monodevelop build?

Thanks in advance,

I had the same problem using United States-International as a Input Language. I fixed this by using a different Input Language. Goto Region and Language and choose English (United States).

Same here, quotes can’t be entered with the “U.S. International - PC” setting.
Workaround: open system prefs, click “language and text”, then “input sources” and enable a second input source (say, “U.S.”).
Finally, mark “allow a different one for each document”.

Now it works, but it’s annoying if you need the original keyboard layout in other apps (very likely).
Seems like a regression, as the previous version didn’t have this bug.

Guys, i found a better solution for this problem.
You can create a code template for the “wrong” double quote.
Then, when you need to create a string, you just need to press the wrong " and , just like we normally do for the while template, and things like that.

Much better, than keep changing the keyboard layout.


FYI, the latest Unity build (3.4.1) has solved this problem.
For me, it works fine now.

Hi!!! the solution for this problem, press shift and press two times the key double quotes! now it’s works!!

The quickest solver for this issue, that i found was to go do the Edit > Preferences and then in the “External Tools” > External Script Editor, choose Browse, then find the Mono Develop from the Unity 3.5 folder, instead of the Unity 4. This way you will use the 3.5’s MonoDevelop, which worked for me…

It’s weird because both Unity 4.x and Unity 3.5 are using Mono version 2.8.2, but one of them can’t write quotation marks :expressionless:

Anyway, hope that helps :slight_smile:

Hi, in windows I changed in the “Region and Language” the keyboard layout
What worked for me was Portuguese (Portugal)

I spent a lot of hours searching for a solution and for me… That’s the best

This thread has shifted quite a few times and I believe not everyone has the exact same problem.
But to let you all know, my problem of not being able to type double quotes " on a MacBook with a US keyboard set to international english has been going on between from Unity 4.0 and until 4.2.
I am happy to report that the new version of MonoDevelop coming with Unity 4.3 now works fine.

I dont know if it will work Properly But …
Open up something … where U can type > " < Quotation mark, Copy it and you will be able to past it into Unity. so you just have to use Ctrl + V
Good day !

I had an analogous error (Unity 4.3.4 Mono 4.0.1)

In my game text, turns out that unity suddenly replaced all the apostrophes with strange symbols. In mono code, the text said Let’s, but in the game it appeared Letā€™s. I found several web developers facing same issue.

The most probable trigger is that I changed the keyboard language in another application while unity was running. Annoying, especially because our game is a visual novel, that is, lots of text. Changing back the input language (spanish - us english) did not correct anything.

Most probable cause is that we used MSWord to write first the text (for the spell checking mainly) and then copy pasted it on mono code. Turns out that MSWord is a ‘rich text’ application. This means that it automatically enriches the text by substituting certain characters like quotation marks and apostrophes to more sophisticated versions. This means that “Hello” is auto replaced by “Hello”. Note the subtle difference in the quotation marks. When copy pasting, the rich text corrections are embedded and Mono does not seem to do a good job in applying them.

Solution: I turned off the auto correction options in MSWord, particularly “Straight quotation marks to typographic” and, well, had to correct and re-paste all the text.

Another solution offered by Jonathan Hedley is his script that converts text copied from MS word into plain text. It can be found here: http://jhy.io/tools/convert-word-to-plain-text

Hope others find this useful.

can any1 plz do tell me that my double quote button is not working in monodevelop4.0

i am using a hp notebook.
Thanx n advance

For people having trouble, this worked for me. https://bugzilla.xamarin.com/show_bug.cgi?id=4205 comment 14:

Default input language can be changed (e.g. Win7) through the following sequence (no reboot required):
Control Panel
Region and Language
Keyboards and Languages
Keyboards and other input languages
Change keyboards...

Change the standard input language to US, this was what solved it for me.

Well,changing the keyboard input doesn’t really solve the problem : Now, you have the quotes but you non longer have the accents … and the reason most of us are using the US International keyboard is because we needed the accents in the first place!

Thanks, mflashbr. It worked here.

However now I can use accents no more… Here’s hoping we have a fix for this ASAP…

I’m also experiencing this problem. What I do is, I type the double quote in the Finder’s Spotlight, then copy it with Command-C. Then press Command-V whenever you need to type a double quote. I didn’t know about the keyboard setting option, so I guess I’ll try that, too.