Unity no longer recognizes any Joystick Inputs

A while back, when I first connected my PS4 controller to my Mac to test with one of my games, it worked just fine. Now, regardless of what kind of joystick I plug in, Unity won’t recognize that there is any Input being entered from a Joystick. The only major difference between then and now was the update to Unity 5. I’m not sure if that may have been what caused the issue, but it’s the only thing I can think of. The Mac itself recognizes that there is Input from both my PS4 controller and my Xbox 360 controller, but Unity doesn’t. I’ve been researching for hours what I could have possibly done wrong, and tried every solution I could find. Unfortunately, nothing has worked, so I come to you guys in the hopes that someone else has had and fixed this problem themselves.

Solved: So after hours of research, it turns out it was the Logitech Mouse that I had installed. The drivers for the Logitech Control Center was apparently overriding the Input to Unity for Joysticks