Unity not displaying textures properly?

So I’m having this weird issue which isn’t making a lot of sense. In my old Unity project, I’d applied the import settings to use legacy, and then I would have a folder with all the textures right in the Unity project. Everything would work perfectly, and all my textures for all my environments and objects would display. I exported my assets from Maya as FBX.

However, in my new project, I’m doing the same thing, except my texture folder is super organised, with folders to differentionate specific environments and normal maps etc. For some reason, normal maps get found on the scene fine, but for actual textures, I have to reapply each one, as the materials show up as grey for some reason before I do. Basic maya colours do appear though.

Folder example = Textures>Self Made Texture>Science Lab>Wall.png

At one point, I removed a texture from a folder and based it in the main texture folder, where all the environmental folders were, and it made that texture work normally. However, when I tried this trick with more textures, it didnt work.

I changed import settings to extract, and it makes the texture files names show correctly, but it doesnt apply the textures to the scenes at all.

I literally don’t understand what I’m doing wrong. Why is the fact that my folder is organised making things worse?

Perform the following one by one on your imported FBXs:

  1. Go to “Materials” tab and click on “Extract Textures…” and choose the folder which will contain imported textures .
  2. Go to “Materials” tab and click on “Extract Materials…” and choose the folder into which Unity extracts materials.
  3. Delete duplicate textures and materials to make sure there is no duplicate (e.g. if there is Walnut_Wood and Walnut_Wood 1, remove the second.
  4. Go back to asset you just imported its textures and materials and make sure there is no missing materials in its “Remapped Materials” section. If there is missing materials, then

a. Click on “On Demand Remap” section to open up.

b. Set “Naming” to “From Model’s Material”

c. Set “Search” to “Project Wide”

d. Click “Search and Remap” button.

e. At this point, you should verify that there is no missing material in this section. If there is still a missing material, you can set it manually by dragging a material (from anywhere in your project, probably _materials, to this slot.

  1. Put the prefab in the scene and make sure it looks right i.e. the textures and materials look OK.