Unity not importing blender animations at all

Hello, i have a terrible problem, i was working with unity and blender files, and everything was great, but for some reason Unity stopped importing animations in my blender file for no apparent reason, i was making a new animation on blender, i saved the file, and all my animations were gone on my proyect window, sometimes some of the animations are imported, this is when i play a little with blender settings, but still, most of my animations are gone. This is a terrible problem for me, and i have no idea how to solve it, please, i need help.

In Dope Sheet, select Action Editor. Name your animation in Action box, click the F button.

Make your animation.

To make a new one click the + button. Don’t simply rename and hope for the best. Make sure to click F. This way, all animations saved under different ‘Actions’ will appear as separate Clips in Unity.

Upon export, make sure ‘Include Animation’ and ‘All Actions’ are checked but you don’t need ‘Include Default Take’.

Make sure to click ‘Import Animation’ under the model import tab. (I shall post pic in comments. Max 2 allowed).

These steps should give success.

I was running into similar issues today. However, my situation was a little different. I was using the Unity .blend importer, and on first load, my animations appeared, but after updating the import settings for the .blend file to add looping, one of my animation clips went missing. I tried re-importing in numerous different ways to no success. I’ve since decided to export FBX from Blender and import that into Unity instead. I think the FBX importer is a lot more stable than the .blend importer.


[none of the other tips worked for me - even FBX failed]

Search your animations for SCALES of 0.

I included some animation keys with 0 as the scale for a few bones, and some of my animations stopped importing. This created inverse matrix issues.

Another side-effect or indicator of a problem was that an annoying Default Take was being included in my animation list in Unity after import.

Since removing all 0-scale keyframes, I can now use the raw .blend file and I don’t have to export to FBX at all.

Tip: If you are getting import errors in Unity from Blender, one useful thing to do is export to FBX and read the error logs in Blender (if they occur).

This is an image of the error that I got with the error at the bottom:

**ValueError: Matrix.invert(ed): matrix does not have an inverse**

Another Tip - How to find the culprit animation without going nuts:

In the Unity animation window you can see where your animation(s) may have stopped importing. Check each animation - you might see an animation with part of the bone hierarchy missing - this is indicative of the problem animation.

Image of bad animation - missing the rest of the armature hierarchy (there are more bones included in my armature than shown here - compare animation hierarchy against your full armature):

@matpneu @Jeeses @getyour411

I’m sorry if this is a late response but I’ve just figured out how to add new animations.

It’s kind of clunky since the first time the program reimports with no problem at all. But you can always manually add animations to the mesh. It’s my best bet since deleting the file and reimporting it is terrible if you have things like animation events and other kinds of metadata.
1: Select your mesh.

2: Press the plus (+) sign.

3: Select the corresponding animation from the dropdown list. Additionaly name it properly!

It’s so simple yet I probably got confused because it auto imports them the first time.

Unity didn’t import additional animations form a Blender file, which I changed and wanted to re-import. My solution was to rename the .blend File. The problem appeared after I set one of the existing animations to loop. I guess unity stores some information inside a meta file, which prevents it from importing additional Animations. And after renaming, Unity is doing an all fresh import of the .blend (cause there is no associated meta file with that name) and voila I got all my animations. Perhaps deleting the Meta-file will do the magic too, but i didn’t tested that.

Export as fbx and change these settings:

to these:

I had the exact same problem, just changed the version from FBX 7.4 binary to FBX 6.1 ASCII and enabled the “Animation” box.

Delete the metafile of the .blend file. Wait until your Unity app understands this. Then save and close Unity app. Bring back the meta file and open the Unity app. You will see the animations working. This much.