Unity on Gear VR with Galaxy S6

For some reason I can’t get Unity to work on the Gear VR.

I have two problems:

For starters, I don’t get the stereo view when I press play in Unity.
It used to give me an error message that the VR runtime wasn’t installed or that there wasn’t a VR device available. After the 5.1.1p2 patch, I don’t get an error at all, but it still doesn’t give me the VR view.

The second is exporting. I have no problems when I export an empty Android build with just a cube in it. I see the app on the phone and it opens normally. When I export an Anroid build with the Mobile VR package on the other hand, the S6 gives me an error message. First it tells me to put the phone in the Gear VR, but after a short black screen I get an AKP security error. I looked at some other posts about this, but no matter what signing I use (unsigned/debug or sign file), I keep getting the same error.

Here some additional info:

  • Unity 5.1.1p2 (with Oculus Mobile SDK 6.0 package)
  • Android Studio (SDK)
  • Oculus Runtime 6.0 (eventhough I don’t know what this does)
  • Gear VR with Samsung Galaxy S6

Thanks,
Ele

Regarding this security error, as far I know ( but personally not tested i´m still waiting for my Gear VR ) Every Gear VR application need a Unique Signature Code for each Mobile Device (Provided by an Oculus android app what you need to install ). Without this signature code you cant run the apk. The reason behind this is the Samsung Policy. They don’t want to let you push your Gear VR app for the public ( at this time ). So because of this you need a unique signature / generated apk for each device (S6+GearVR). This means you cant share whit your friend an apk what you generated for your device. He will became the same error as you. In this video tutorial this guy explain it well somewhere in the middle of the video: Youtube Video Tutorial

Okay, I found the answer to my second problem.
The app I used to get my Android device ID, returned the wrong ID number.
I found out the right ID number during the build of the OVR export. At the end when it’s done compiling it shows the device ID: “Pushing new content to device DEVICE-ID-HERE [MODEL-NUMBER]”. This was the correct ID which I then used on the oculus tools page to get the signage file. For those who don’t know yet. Put this file in the folder: Assets/Plugins/Android/assets/