Unity opens to a blank page after project has been exited once

Whenever I open a project Unity opens to a blank screen. I’ve tried reinstalling unity which works, but then when I quit a project and reopen any project, it happens again. This happens for any project in Unity versions 2017.3.1f1, 2017.4.6f1 and 2018.1.6f1 (I haven’t tried any other versions). Reinstalling unity fixes the problem for a little bit, until I close a project and open one again.

Right clicking the place where the hierarchy window is supposed to be still brings up the right context menu, so it seems this is a visual problem.

I’ve searched for a solution for hours and found none of them to work. Here’s some of the links I found which don’t work for me, but might work for other people:

Here’s a screenshot of what it looks like:

If anyone knows a solution I’d be very happy to hear it.

Edit: It’s probably important to mention that I’m using Unity Hub and this problem never occurred before I installed it. So perhaps it’s got something to do with that

I uninstalled Unity Hub and downloaded and installed the latest version of unity normally. This has fixed the problem. So this seems to be a Unity Hub problem. Strange though, as I previously used Unity Hub on a different device without issues. Will open a ticked for this bug.

Edit: Nevermind it still happens

Edit2: This finally fixed the issue: https://forum.unity.com/threads/editor-opens-on-blank-screen.539360/