Unity Personal 5.2.1f1 splash screen and xcode 7

Hi everyone,
I come across a strange issue using Unity Personal Edition and iOS free license

I usually work with Unity on Windows, but with the latest release of xCode which allows to test an app on device without a paid developer account I wanted to give it a try.

The first time I builded it from my mac and in xCode I only setted the bundle identifier and my Apple ID:
everything went fine (except 200 or so warnings in xCode while building) and I was able to test my app on my iPhone 4s (iOS 8.4):

  • Unity splash screen with animation and then the app started as expected.

The second time (after few improvements on my app on windows) I tried to build again from my mac:
I used the same build settings as the first time and everything seemed to go fine (200 wanings again in xCode, but no critical errors), but this time:

  • No Unity splash screen (only a gray screen) and the app crashed on my device (sometimes it started, but very randomly and without the Unity splash screen)

Since then I tried multiple times building and testing on my device with no luck:

  • I tried nearly every different build and player setting

  • Creating a new project and importing all assets from my previous one (both on Windows and on the mac)

  • changing the bundle identifier

  • switch platform and come back to iOS

  • tried xCode 7.1 beta

I noticed that the building process in Unity gives me some warnings:

  • Unknown file extension .dat on UnityEditor.HostViewOnGUI() (I see this 2 times in the console for every build I do)

  • No splash screen provided for [list of devices]

The strange thing is that if I provide a splash screen (keeping the “Use unity splash screen” option ticked), I get the same behaviour but i see the spalash screen I provided istead of the gray screen

In addition to this with some builds xCode gives me some ERRORS such as:

-Could not open file Splashscreen-iPhone.xib (or iPad)

and failing to build.

I tried reinstalling Unity on my mac too.

I know the are issues with unity personal and iOS deployment since 2011, but I can’t manage to understand why it worked perfectly the first time, decently the second one and now I’m stuck without being able to test on my device.

Does anyone have the same issues and found a fix/workaround?
I want to keep the Unity splash screen on my app (I think is cool and i don’t want to break the license agreement), but this issues are making me mad!
Any help is appreciated.

Edit: Tried with Unity 5.2.1p4 and iOS9 on my device, resulting in the same behaviour: no unity launch screen on device and app crashed.

I’m taking a wild guess but if you compile in a Windows machine for compile into an iOS device, It may yield unexpected results…

try compiling from a Mac