Unity Pro won't default to Visual Studio full edition

I am using Unity 3.4 Pro and Visual Studio 2010 (full version, not express) at my job. I have set the default editor to Visual Studio 2010 in my Unity preferences. When I ‘sync Monodevelop project’ I get the the progress bar that says “Starting up Visual Studio…” So I double click one of my C# scripts and I again get the “Starting up Visual Studio…” popup, but then Monodevelop opens instead. I have tried uninstalling and reinstalling Unity with and without Monodevelop and I get this every time. My coworkers don’t seem to be having this issue, but they’ve all looked over my setup and can’t see anything wrong.

Is anyone else out there encountering this?? My searches have been fruitless…

dbuck: So, unity wont open visual studio for me anymore, theres a small window that says ‘opening visual studio’ and then monodevelop opens, and a dead devenv.exe ends up in the task manager, has anyone else run into this?

support: dbuck: does your vs2010 install path include “Microsoft Visual Studio 10.0” ?

support: one sec

(I was in the middle of repairing the install, just in case it was the Visual Assist trial that i had uninstalled causing the problem)

support: Set your default script editor to VS2010

support: close MD, VS, and Unity

support: delete all .sln and .csproj from your project folder

support: start Unity

support: Choose “Sync MonoDevelop Project” from the Assets menu

support: dbuck: this happens when VS returns a failure status when opening the script project

support: this can be when: it needs to pop up some nagware dialog (resharper trial, etc.), the solution has been generated for a different version of VS, VS actually fails

(I’m STILL in the middle of repairing the install, so once it finishes i’ll edit whether the answer is correct! but, this was a talk with the guy who did the monodevelop integration!)

In Unity forums: http://forum.unity3d.com/threads/99625-After-upgrading-to-Unity-3.4.0f5-double-clicking-Console-window-won-t-open-VS-2008

Apparently its been reported as a bug. Whether its getting fixed... Who knows. I reported it as a bug in Unity toolset report feature as well.

I’m having this same issue. I found that leaving renaming the monodevelop.exe file (C:\Program Files (x86)\Unity\MonoDevelop\bin\monodevelop.exe) so that Unity can’t find it worked sometimes, but is still temperamental, but then you can’t use it for debugging scripts also. Some combination of using sync project, opening scripts from unity, and opening the project .sln file manually seems to get it to work.

There are definitely some bugs in the system, I’ve been trying to figure it out by watching the processes opening with Process Explorer, and it seems that every time you double click a script it opens a new instance of devenv.exe with an -Embedded argument, each using ~80mb memory. It would be interesting to see if this also happens on machines where it is ‘working’.

This fixed it for me... FINELY.

Dunno if its the newest version or the way I did this. Either way it worked and I hope it helps you guys.


First, I used the VS2010 DVD to do a complete uninstall of VS2010.

Second, I uninstalled Unity3D.

Third, rebooted PC.

Fourth, reinstalled VS2010 to DEFAULT install location. C:/ etc...

Fifth, patched VS2010, and restarted PC.

Sixth, Installed Unity3D 3.4.1 to its DEFAULT install location.

Seventh, started Unity3D, selected VS2010 from preferences. Killed Unity.

Eighth, re-started Unity3D, double clicked c# script, and BINGO!!


It built the Unity VS2010 solution and started VS2010 as though there was never an issue.

Hope it works for you.

I had the same issue as described in the top post, and got a solution from “ToreTank” on #unity3d @ freenode…

The problem seems to be that VS is too slow when it comes to starting up, and Unity recognizes this as a problem and makes some kind of fallback, and opens MonoDev instead. All I had to do was rename the MonoDev application so that unity cannot find it. This made it impossible for unity to make that fallback resulting in VS getting enough time to actually start up.

I had Visual Studio set to run as administrator. This would result in a confirmation dialog each time Visual studio was started which is what unity didn’t like. Disabling the run as administrator on the Visual Studio link fixed the problem

I was having the same problem after I had set the Compatibility mode to “Run this program as an administrator” for Visual Studio 2010. I was able to fix this issue by also selecting Unity to run as an administrator.

Hi guys,
I have found a solution to be able to kind of work this problem out.
It seems there is a problem with the opening of visual studio and the sln file.
So all you have to do is open the file yourProject-csharp.sln not yourProjet.sln (those 2 files are automatically generated by unity) and then you can have all your interactions back between Unity and Vs.
Hope this can help you out