Unity Project closes immediately after opening, without any errors - What could be the cause?

I open Unity Hub, select the project, it launches the splash screen, then begins to load the editor, the loading bar appears and starts filling, and then Unity just closes. No error messages appear at all.

The project is collab enabled.
It consists of only scripts and a few standard materials and simple GameObject prefabs (just sprite renderers with default tile textures).

Some Hub processes are still running in task manager after the close.

So far I’ve tried:

  • Deleting the project’s Lock file and attempting a restart - issue persisted.
  • Restarting my PC - issue persisted.
  • Ending processes in task manager and restarting - issue persisted.
  • Building the project solution in visual studio to check for errors - no errors found, build successful
  • Upgrading the project to the latest version of Unity (from 2019.3.12f1 to 2019.4.1f1) - issue persisted.
  • Backing up my changes, removing the project from the list in Hub, re-downloading from collab and re-importing my changes - the project opened, until i tried to open one of my custom editor windows and then the issue re-occurred
  • Revoking and re-allocating my unity teams seat on the project in the project Dashboard - issue persisted.
  • Copying my scripts across into a blank project to check for compiler errors - no errors found, the issue hasn’t yet re-occurred.

I’m writing this post because i’m dreading the issue continuing in a fresh project, and ideally i would like to not keep creating brand new projects and setting up collab and re-allocating seats every time this happens.
It’s entirely unclear to me as to whether the issue is with my code, or with the project, or some licensing error, or something else.

Can anybody shed some light? Happy to post more info, but not sure what would be relevant.

This particular issue is starting to really hurt my productivity. I have a work and home environment both using unity and both have been effected by this.


At home:
I installed a new PCIE express wireless card to improve my connection. After I did this unity stopped working. I’d launch the HUB and click the project as I do every day… year after year… and the editor splash shows up and the it just goes away. Nothing tells me that there was an issue. It just goes away. After doing some reading on this I figured out that it was because I had disabled my old wifi connection to make sure my new card was the only connection. Once I re-enabled the old adapter it worked again.


At work:
I had a hard drive fail and had to reinstall everything. Now I want to use Unity and get some work done and it is doing the same thing! Splash shows up… goes away… no sign of failure… The HUB says my license is valid and activated… Only this time ALL my adapters are active. I can’t get this to work and am sad that money has to burn due to this issue

Well happened to me as well and the reason was I was running thru vpn, I disabled the vpn and all well.