Unity Qualcomm API

Does Unity Android Qualcomm works with Android 2.1.. Has anyone got working AR on Unity Android? I just build and test the sample application that the Qualcomm give and it doesn't run on my Android 2.1..

Note: I commented the line GL.InvalidateState() as it is not the the Unity Engine. What does it do actually>

It should work with Android 2.1. But more importantly: if GL.InvalidateState() is not found that means you're not using the Unity 3.1 release. The Qualcomm plugin requires 3.1.

Questions (and answers) regarding Qualcomm AR and Unity can be found here: https://ar.qualcomm.com/forums/forumdisplay.php?f=7