Unity Ray-Tracing Build Issue (Materials become invisible)

HDRP Ray-Tracing Build Issue,Unity Ray-Tracing Build Issue (Materials become invisible)
Hello, I’m working on a simple ray-tracing demonstration project, this is how it normally looks when playing within the editor or generally on the scene view:

So everything seems to be working as should, however soon as I go to build the project itself, any material that is using a Ray-Tracing rendering pass disappears. The build mode is set to PC, Mac & Standalone and it is using DirectX 12.

This is what the built exe looks like:

Now I am using a 1080ti, which isn’t a genuine ray-tracing capable card and lacks RT-Cores, however, I know that NVIDIA is now allowing older 10 series cards to simulate it. So wondering if this could be the issue, but then again I have no problems when in the actual inspector. I’m using the latest graphics driver and my editor version is 2019.3.7f1

Thanks

i have the same problem. did you figure this out?

There is a limit to how far rays can render. If your room is particularly large, no rays will hit the walls and nothing will render. You can verify this by getting very close to the walls after activating raytracing. If parts of the wall start getting rendered in a sphere around the camera, the following resolutions may help.

Possible fixes:

  1. In the ray tracing settings (global illumination override) increase the ray distance. As of this post, the max distance is 50.
  2. Scale down everything in your game.

When I had a similar issue I scaled down the game and everything worked swimmingly.

Make sure you have the “Recursive Rendering” override added and enabled in your Sky and Fog Volume in your scene. ,Make sure you have the “Recursive Rendering” override in your sky and fog volume.

I have the same issue. In editmode and gameview everything looks fine. after building every raytraced material disapear. Is someone out there for help?

I’ve seem to have fixed the issue, if you’re build mode is set to x86 it won’t render anything with a raytraced passthrough, however seeing the build to x86_64 fixed the issue for me and things are now being rendered properly! 173765-fixed.png