Unity Recorder with URP, Captureing Alpha Not Working

Hello Forum, I am having an issue capturing alpha to PNG using Unity Recorder. I set my camera background to Solid Color and Black with 0 transparent. Set the target camera to tagged camera and pointing to the camera that I want to capture. I checked the “Capture Alpha” checkbox on. I think this is the setting that I need to set when we were still using the old render system but doesn’t seem working in the URP. Does anyone know how to solve this? Thank you in advance.

Successfuly captured with "Source = Texture Sampling"180722-screenshot-52.png

Same here. Capturing alpha isn’t working nor with HDRP.

Unselect “Post Precessing”,

When I set the Color Formats to R16G16B16A16 in HDRP, I was able to get Alpha output. Normally URP and HDRP render R11G11B10. I guess alpha is not included in the output because there is no alpha channel.

Hi, I cannot make the Get Alpha Output button to appear in HDRP; I have changed the colour in Settings to R16G16B16 , but I only have a greyed out option of sRGB, sRGB.
Any suggestions please ?

Same here - Bump!

… from https://unitytech.github.io/unity-recorder/manual/index.html

“Capture Alpha Check to include the alpha channel in the recording. Uncheck to only record the RGB channels. This property is only available when Format is WEBM. This property is not available when Capture is Game View.”

Still can’ get anything to work. Tried everything - rendering to a rendertexture, separate camera, other colour formats. Gonna have to chroma the background out, NOT ideal

I had the same problem trying to capture ProRes with alpha channel. It turned that in addition to setting camera background to Solid Color and Black with 0 transparent, I also had to turn off post processing and HDR in the camera settings for the alpha to be correctly captured.