Unity refuses to open on my mac!

I have recently downloaded and installed unity. We use it at work and I wanted to get to grips with it in my spare time. However unity just refuses to start...well it actually starts but no window appears so i navigate to new scene/project. At this point it crashes straight away!

I also run Parallels on my mac and have downloaded unity for windows just to test...and it does the same thing!!!

Please help.

iMac 10.5.8

2.16 GHz Intel 2 Duo

2gb ram

250g HD

strange requirements seem fine also had windows 7 on parallels and that worked for me

I have tried unity for windows again on parallels and it worked....apart from all the menu and text just being black boxes!!!So really can not use it. Im really starting to get angry as nobody else has had this problem. Ive downloaded unity 3 5 times now and still it does not work.

I have also tried moving the default project directory as someone said it might be corrupt!

Im now thinking it might be a problem with my macs GRFX card:

ATI Radeon X1600:

Chipset Model: ATY,RadeonX1600 Type: Display Bus: PCIe PCIe Lane Width: x16 VRAM (Total): 256 MB Vendor: ATI (0x1002) Device ID: 0x71c5 Revision ID: 0x0000 ROM Revision: 113-xxxxxx-139 EFI Driver Version: 01.00.139

Please help!!

Are you running this in simulated environments? I've had similar problems when trying to run it in a VMware workstation.

My guess would be the graphiccard/softwaredriver for same. Try to update it or disable some of the hardware acceleration to see if thats the reason. I dont recommend to run without hardware acceleration, but its worth testing to locate if its the software/hardware that fails or something different.