Unity Remote 3 Stuck On "Waiting For Game View"

I have a quick question about using Unity Remote 3 to test a game that’s my group is developing for the iPad. The remote works perfectly at home, but when we meet on campus it never gets past the “Waiting For Game View Press Play” screen. Is there something that I’m missing here?

When I’m at home I’m connected to my WiFi on both my Macbook and my iPad (3rd generation). With Unity Remote open and Unity running, I touch “local” under “Bonjour”, and then “myWiFi” under “Domains”. The game view is immediately displayed on my iPad for testing as long as I have pressed played inside of Unity.

When I’m on campus I’m connected to the school’s WPA2 WiFi (or the guest Wifi) and my iPad is as well. I touch “local” again, but there’s nothing listed under the domain. I tried googling “What’s my IP address?” and entering it with the “Enter IP Addr.” button the bottom. This send me to the “Waiting For Game View” screen, but nothing ever happen.

Any thoughts on this? I’m using Unity Remote 3 and running Unity v3.5.6f4. (And yes, “Show Image:” is on “YES”.) :slight_smile:

“I tried googling “What’s my IP address?” and entering it with the “Enter IP Addr.” button the bottom” <------ That’s wrong, What you tried to do there is find your EXTERNAL IP, wich is ofcourse of the schools networking provider, you should try opening terminal and try to find your LOCAL IP Address, I’m not sure what the command in the terminal is because I don’t use an MacBook / Mac OS, I think it’s “ipconfig getifaddr en1” I think that’s for WIRELESS Connections. You could always try using the Network Utility

Start the Network Utility application, located at /Applications/Utilities/Network Utility. Your local IP address can be found on the first page.

If you are part of more than one local network, additional IP addresses can be found by selecting the appropriate Network Interface.