Unity Remote 4 stopped working

After going through the process of downloading the appropriate Android SDK, NDK and Tablet drivers, Unity Remote worked perfectly for a few days. However, recently it seems that no matter what I do, Unity Remote will not “pick up” the fact that I’m in Play Mode in the Editor (nothing happens on the tablet screen).

Are there any methods to “reset” Unity Remote and make it work again?

Occasionally I can get it working through a seemingly random combination of restarting computer/tablet, restarting Unity/Unity remote, enabling/disabling debugging mode on the tablet, changing the USB-configuration on the tablet to PTP (Picture Transfer Protocol), and toggling between “No-Device” and “Any Android Device” in the editor. As you can imagine, this is very hit-and-miss as well as hugely time consuming.

I’m using the latest version of Unity Pro (5.2.3f1) on Windows 7. I’m running Unity Remote 4 on an HTC Nexus 9 tablet.

The general method I use to use unity remote is in these steps:

  1. Turn off Unity Editor.
  2. Open Unity remote in my device Samsung Galaxy S4
  3. When it connects I use it as PTP same as u do.
  4. Go to Edit>>ProjectSettings>>Editor>> & Select>> Any Android Device
  5. Most of the times my unity remote stops responding so I close it on phone and turn off unity, then turn remote On again and open unity editor… It hectic but yes I do all this.

You can follow this process once if it does’t work just reinstall unity remote from PlayStore…

Please let me know whatever the result is. Thanks

Hello, i had a similar problem. Solved it by re-instaling unity remote 4, then built and ran the application with my android device…and then it finally worked again.

However, make sure that you have developer options and USB debbuging mode on.