Unity Remote 4 won't work at all!

Guys, I have a huge problem. I can’t make Unity Remote 4 work at all! I followed like 5 tutorials all over the internet and nothing made it work so far. The problem is simple: I connect the device via USB to the computer, hit play on Unity and nothing shows up on the device. I tried Build & Run and it doesn’t work either.

I’m using Windows 7 64 bits & Nexus 5 version 4.4.4, Unity version is 4.5.2f1. Please help, I’m going nuts!! lol

A list of everything I’ve done so far:

  1. Installed latest JDK and checked it was for 64 bits
  2. Installed latest Android SDK and checked it was for 64 bits
  3. Installed Google USB Drivers and updated the driver for Nexus 5
  4. The device is detected on the system (but not on Unity)
  5. Installed everything needed on Android SDK Manager
  6. Restarted ADB server via CMD and made sure my device was there
  7. Allowed Mock Location, USB Debugging & Camera (PTP)
  8. Edit → Project Settings → Editor → Any Android Devices
  9. Edit → Preferences → External Tools → Chose the right folder

There goes some pictures of everything I could think of [I have more pics but I can post up to 2 pics]. Am I missing something?? If you guys need ANY info to help me solving the problem please do ask it, I really wanna make it work! Thank you!!!

Do steps in following order:

  1. Connect device
  2. Make sure that device is listed after “> adb devices” command (dont need to do that everytime actually) if not - FIX THAT FIRST
  3. Run unity
  4. ???
  5. Profit :slight_smile:

Most important is to firstly connect a device and secondly run Unity so it could detect connected devices at start, i guess Unity does it once only at start.

  1. Close Unity
  2. On Mobile Enable USB Debugging and Mockup Locations (have read this is important)
  3. Launch Unity remote
  4. Connect Mobile
  5. Once ADB is connected start Unity
  6. Change To any Android Device in Edit/Project Settings/Editor

These steps work for me every time on any pc

YEah I was also having the same problem. But it started working when I tried after restarting both my mobile and laptop. And Repeating the normal connecting procedures.

Any other suggestions? Please guys, I really need help :((((((

Did you download and run the Google Play version of Unity Remote 4?
You need to do this unless you have Unity Pro.

If this doesn’t fix your issue, here are a few other things to check:

  1. Is your phone connected to the computer as an installer? Did you properly install Google’s drivers for the device? (Yes to both if you can Build & Run in Unity and your game gets pushed to your phone successfully.)
  2. Make sure you have the Remote.unity scene open in Unity; it isn’t loaded by default.
  3. Run the Google Play version of the app on your phone BEFORE you hit play in Unity. In Unity Free, you can’t just Build & Run for Android because you need Unity Pro for socket support which is why you need to run the Google Play version on the phone and just press play in Unity.
  4. My GS5 tends to disconnect from my computer after about 20 seconds which is just long enough for me to load my game onto my phone, but not use this app. To check if this might be your problem, try unplugging and replugging your phone and then press play in Unity while your phone is still in installer mode. If your phone gets the stream from the computer for about 5 seconds and then fails, then you have a hardware problem and probably need to use a different android device.

Follow this steps: Run apps on a hardware device  |  Android Studio  |  Android Developers
I’t works for me

I was also having the same trouble as above! It was very frustrating.

Installing the my specific phones Drivers is the only thing that worked for me, besides following the steps on the Unity Documentation page.

Hope this helps!

Try updating to unity 5, as soon as I did that it worked for me! Before then I had tired everything under the sun to get it working and nothing helped

thanks kroval this fixed my issue

for adb i followed these steps : http://www.howtogeek.com/125769/how-to-install-and-use-abd-the-android-debug-bridge-utility/

@psypol

This has indeed helped. I have installed everything related to SDK, I have also installed my Samsung Drivers.

I have:

  1. Enabled USB Debugging, and despite my manual process of enabling it, when I plugged in my phone after installing drivers it asked me if I want to enable USB Debugging
  2. Followed @smallbit instructions
  3. Linked SDK in my unity as well as set the preferences in Editor to play on Android Devices

There’s a lot of steps, but once you do them properly it works.

Also make sure you go to your Android SDK folder, open SDK manager then make sure your android version and google usb driver is checked in if youre using a nexus phone and then click install.

Ive made a new one, it’s not free, but it works with the latest versions.

I do give free versions for educational reasons!

Unity Remote may not work until you have more than one item listed in ‘adb devices’.
For example :
79494-capture.png

Kill both “emulator-xxxx” before starting Unity to have no problems.