Unity Remote 5 not working with Unity 2019.3

I’ve always used Unity Remote 5 with Unity and it has always worked fine.
All of a sudden I started Unity and nothing worked. The app wasn’t showing anything and in the editor i couldn’t even click in the game panel.

I tried:

  • Uninstalling and reinstalling Unity
  • Uninstalling and reinstalling Unity Remote 5
  • Upgrade to a newer version of Unity
  • Reinstalling mobile drivers

The SDK and JDK are installed with Unity and I’ve no problem with them.

The mobile is connected as MPT (I’ve tried also PTP). USB debug is active.

The Unity console doesn’t show any message.

This piece of code doesn’t work in any way:

private void Update()
{
    if (Input.touchCount > 0)
    {
        Debug.Log("Screen touched");
    }
}

When I build the game everything works, but in the editor I have no ways of testing my game. Please, help.

I resolved the problem by creating a new project and importing all the asset. I think that the problem was in the project, that got corrupted after the Unity update.