Unity Remote 5 NOT WORKING

I have tried so many things but I CANNOT get Unity Remote to work! I have the Drivers installed, the JDK, the SDK, and anything else you need. I have restarted my PC, I have launched the application and Unity in the correct order. I really don’t know what to do. I have spent 6+ hours trying to fix this problem and I have found no hope. PLEASE HELP!

I know it’s a bit old question but it might help to someone that stumbled on this problem.

Have you tried listing android devices via adb devices? You can find adb in \AppData\Local\Android\android-sdk\platform-tools if you have installed sdk via Unity installer so just cd there and execute command. When I listed devices, I noticed that there are multiple emulator devices running. Restarting Windows did the trick for me. I just did adb devices once more after restarting the Windows

well i have a problem with unity remote as well…
It was working perfectly and i could check android builds when i connect my iphone to ex- my laptop but now when i connect my phone it is show on the editors list but when i click play it is not show on game list (the one you choose aspect). It says " remote deviece is not connected. "
any idea??

I’ve been following the answer by shemz, but what really made it work is changing my build settings to Android. I was able to change them back to desktop, exit Unity, and reenter and still have it work. Try that, anyone who’s looking this up years from now!