Unity ruins image horribly

Ok, so I decided to finally make the gui elements of my game.
I imported my images for the buttons into unity. And they have been distorted horribly by Unity.

Original image:
alt text

Image after importing to Unity:
alt text

I read on some other threads and stuff that you have to play with the shader or something, but nowhere in the import settings is there an option for that. I can either keep it as a texture, gui, etc but no option lets me do anything any solution google has provided. I’ve tried all/most fixes for this, but none work even slightly.

Thanks for your time

Try this, select your gui texture in project folder, in inspector set texture type to gui, filter mode Trilinear, size (depending on your texture size), and format to truecolor.

I can’t see the images (it sounds like some were linked), but we’re also doing our GUI for a game right now. If you’re using Unity’s GUI and a custom GUISkin, one of the settings for your styles is Border. This slices your texture’s sprite into parts, which Unity will stretch individually (like how they have their default button) instead of stretching the texture as a whole to fill an area.

You can also set your texture in Unity to use Advanced options:

  • Non Power of 2 > None
  • Wrap Mode > Clamp
  • Filter Mode > Point (for pixely GUI) or Bilinear or Trilinear (for smoother GUI)
  • Format > Anything uncompressed or Automatic Truecolor

I use to have problems with GUI images in unity appearing blurred, this is what I did to correct the problem.

1.) click on the image in Unity, and view it in the inspector tab

a.) change texture type to ‘Advanced’

b.) set non power of 2 to ‘None’

c.) check read/write enabled.

d.) set wrap mode to ‘clamp’

e.) set filter mode to ‘point’

f.) At the bottom, make sure that the Max Size is greater than the size of your image.

g.) Set Filter to either Automatic True Color, or RGBA 32bit

2.) Check the quality settings by going to edit → project settings → quality
Make sure that ‘Texture Quality’ is set to ‘full res’.