Unity says Android SDK version is 0.0?

I’ve been trying to compile my game to test it on my phone. I’m using Unity 2018.4.22f1. As the hub does not allow you to download integrated SDK, I tried the command line version but couldn’t get that to work at all. So I downloaded the full Android Studio. It comes with SDK 29. I located the correct SDK folder, and the Preferences accepted it. But when I try to build, I get told SDK version is 0.0. I have tried SDK 26, with the same result.

I have no idea what to try next.

XOG0802211638