Unity says scripts don't exist...but they do...

Hello, I am not sure what happened but all the scripts in my project are not loading. Every single script has a little error message under it saying “The associated script cannot be loaded.” When I delete the components and try to re-drag and drop, I get a “can’t add component because it doesn’t exist” error. I have checked and double checked that the names of the scripts match their classes, and I am at a loss of what to do. Can someone please help me? It was working before…

UPDATE: I think I fixed it! I was getting lots of complier errors and per suggestion I fixed them. So the scripts exist again. Thank you everyone!

Hey there,

What I would suggest is trying to delete the Library folder in the root of your project. This folder is auto generated when Unity opens if it’s missing. It can lose references and deleting it can force Unity to update. (This happens a lot in 4.6)

Try start a new project and import the scripts in. I’ve had issues with projects getting corrupted as well.

Hey, this is a lot late, but I fixed it. It turns out that if there are any compiler errors in your script, the script won’t load until you fix them. But I will keep all this in mind in case I get this error again and I don’t have errors!