Unity Scene and Hierarchy Empty when Opened

My scene does not show anything on the terrain nor is there anything in the hierarchy. It does, however, have all the assets in the appropriate folders and the file size looks appropriate. Is it possible my scene could have been wiped clean? it was last updated 3 hours ago. I spent about a week on this and it’s a lot of lost worked if that’s the issue (I know, i should have backed it up)

I had the same problem: the Hierarchy panel was empty and I thought I had lost everything. Then I realised, that I just didn’t load a scene.

Go to your Assets folder and open a specific scene (.unity) - for me everything was there again.

Maybe you installed an older version of unity on the other machine? This was my problem. Three of my scenes opened and the other 5 was blank…So i upgraded to latest version to match my laptop where i created them. Worked for me. so make sure your versions are identical. It took me a day to figure that out. Good luck. Hope this helps someone.

try to exist the project, and open the project again. worked for me. from old version unity to new version.