Unity suddenly compiling everything all the time...

This is one of those annoying problems you see happening to “other” programmers!

Since a couple days ago. Whenever I make a small change in one script. Unity seems to go “beachball” and (I assume?) compile lots and lots of stuff, it takes up to 10s of seconds.

I swear, further, it does this on all the macs, not just one.

Is there perhaps just a simple setting I’ve thrown on the project, or … ?

Has anyone seen this? Thanks!

While not the specific solution here, it’s worth noting that:

Unity has 4 phases (levels) of script compilation. If any level is modified, that level, and all higher levels are recompiled. Check them out HERE.

One reason scripts can take a long time to compile, is if one makes a change in a script within the Standard Assets. Doing so causes every script to be (re)compiled.