Unity Thinks I Have Z Instead of W Button

i really need help, time ago i had a problem where unity didn’t let me use the W button.
now by playing Atmosphir i know why: Unity sometimes thinks i have an old keyboard (Z Instead of W etc), i had this issue in a lot computers.

can this be fixed, please?
Thanks

For Anyone who has this issue, here is how i solved it:

  • open Unity, go to Unity|Preferences|keys|View FPS Forward |and press w in the key text input. If is a z or something other than w, go on.
  • add a new keyboard layout by going to system settings| keyboard|input sources|input sources and check the checkbox on the one with the U+ icon: Universal(Unicode hex)
  • now close unity
  • once closed, switch to the Universal keyboard by clicking on the flag in top right of mac toolbar
  • Open unity
  • Test again like in step 1. This time it should display w
  • now switch back again to your country keyboard
  • Close Unity
  • Open Unity and now when you test step 1, it displays proper w even with your country keyboard :slight_smile: