Unity Web Player: Crashes

I have a unity web player hosted on a web server. When I play it locally the player loads fine, however, when the player is accessed from the web server it always crashes. The unity logo appears and the loading bar fills but after that it crashes out the whole browser.

To test that the crash was not part of my code I created a quick scene that consisted of a button.

The player wouldn’t even load this lightweight scene. What is wrong with the setup of my server or my code? I am at a complete loss.

Here is the stack trace from the error log:

========== OUTPUTING STACK TRACE ==================

(0x0445B678) (webplayer_win): (filename not available): UnityWinWebStartData + 0x5029f
(0x0BB75F6B) (Mono JIT code): (filename not available):  (wrapper managed-to-native) UnityEngine.Resources:Load (string,System.Type) + 0x2b (0BB75F40 0BB75F8F) [03BB4D20 - Unity Child Domain] + 0x0
(0x0BB75F2E) (Mono JIT code): (filename not available):  UnityEngine.Resources:Load (string) + 0x16 (0BB75F18 0BB75F33) [03BB4D20 - Unity Child Domain] + 0x0
(0x0BB74BF7) (Mono JIT code): (filename not available):  LoadClasses/$Start$53/$:MoveNext () + 0x67 (0BB74B90 0BB74E5D) [03BB4D20 - Unity Child Domain] + 0x0
(0x0BB74F39) (Mono JIT code): (filename not available):  (wrapper runtime-invoke) <Module>:runtime_invoke_bool__this__ (object,intptr,intptr,intptr) + 0x41 (0BB74EF8 0BB74FA2) [03BB4D20 - Unity Child Domain] + 0x0

And the log where the crash occurs:

Direct3D:
    Version:  Direct3D 9.0c [nvd3dum.dll 9.18.13.1106]
    Renderer: NVIDIA GeForce GT 610
    Vendor:   NVIDIA
    VRAM:     1999 MB (via DXGI)
    Caps:     Shader=30 DepthRT=1 NativeDepth=1 NativeShadow=1 DF16=0 DF24=0 INTZ=1 RAWZ=0 NULL=1 RESZ=0 SlowINTZ=0
Begin MonoManager ReloadAssembly
Platform assembly: C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\Data\lib\UnityEngine.dll (this message is harmless)
Non platform assembly: C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\Assembly-CSharp-firstpass.dll (this message is harmless)
Loading C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\Assembly-CSharp-firstpass.dll into Unity Child Domain
Non platform assembly: C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\Assembly-CSharp.dll (this message is harmless)
Loading C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\Assembly-CSharp.dll into Unity Child Domain
Non platform assembly: C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\Assembly-UnityScript.dll (this message is harmless)
Loading C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\Assembly-UnityScript.dll into Unity Child Domain
Non platform assembly: C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\Boo.Lang.dll (this message is harmless)
Loading C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\Boo.Lang.dll into Unity Child Domain
Non platform assembly: C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\System.Xml.dll (this message is harmless)
Loading C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\System.Xml.dll into Unity Child Domain
Non platform assembly: C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\UnityScript.Lang.dll (this message is harmless)
Loading C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\player\Stable3.x.x\UnityScript.Lang.dll into Unity Child Domain
- Completed reload, in  0.335 seconds
<RI> Initializing input.

<RI> Input initialized.

desktop: 1366x768 60Hz; virtual: 1366x768 at 0,0
Platform assembly: C:\Users\Nick\AppData\LocalLow\Unity\WebPlayer\mono\Stable3.x.x\Data\lib\System.dll (this message is harmless)
Crash!!!
SymInit: Symbol-SearchPath: '.;C:\Users\Nick\AppData\Local\Google\Chrome\Application\30.0.1599.69;C:\Users\Nick\AppData\Local\Google\Chrome\Application;C:\Windows;C:\Windows\system32;SRV*C:\websymbols*http://msdl.microsoft.com/download/symbols;', symOptions: 530, UserName: 'Nick'
OS-Version: 6.1.7601 (Service Pack 1) 0x300-0x1
C:\Users\Nick\AppData\Local\Google\Chrome\Application\chrome.exe:chrome.exe (001B0000), size: 868352 (result: 0), SymType: '-exported-', PDB: 'C:\Users\Nick\AppData\Local\Google\Chrome\Application\chrome.exe', fileVersion: 30.0.1599.69

Thanks in advance :slight_smile:

I’ve had the same issue when going to a web based server. The way I got around it is in the HTML file where it reads

unityObject.embedUnity("unityPlayer", "WebPlayer.unity3d", 1286, 804);

change it to

unityObject.embedUnity("unityPlayer", "WebPlayer.jpg", 1286, 804);

and then change your .unity3d extension to .jpg (it should ask are you sure you want to convert) say yes. Only do the above for when you are putting it on the web server.