Unity Weird Inspector Layout Behavior: Can't Scroll To the Bottom of Component Fields

So i got this weird issue where i can’t scroll to see the bottom fields of a component (Ther’s no scrollbar, and scrolling with the mouse doesn’t do anything) I have to collapse many of the other components, to give enough size for the fields i want to see to come into view. As you can see in the image below some of the fields overlap with each other. Weirdly enough it only happens with the project I’m working on. it doesn’t happen when i open other projects.


I tried restarting the pc, and relaunching unity again and again but to no avail!

Any idea as to why this is happening and how to fix it? [Unity 2020.1.12f1]

I confirm I had this randomly happening to me this week without any clear idea as to what causes it. Had to restart Unity and it just worked without issues. I am at this moment just doing basic tutorials to refresh my unity knowledge so using exclusively standard Unity without any packages plugins or any other 3rd party items . Version is Unity 2020.1.8f1 and behavior is identical to OP.

I have the same issue and it makes things sooo hard… scrollbar gone and so is the the Sprite Editor as OP mentions

I have no clue to how to get rid of this…it is kind of a showstopper in many cases :frowning:

Same happening to me. Created a new project with the HDRP template using Unity2020.1.4f1 Personal and couldn’t even read the HDRP readme asset because the inspector wasn’t scrolling - without me actually touching anything.

idk what caused it, it started happening to me a couple of days ago, I finally managed to fix it by:

  1. Closing Unity
  2. Back up the “Library” folder inside your project
  3. Delete it
  4. Load your project and wait for it to generate the folder again
    4.2) It’ll show a lot of nullException errors in the console and the scene and game windows will apear empty, don’t worry
  5. Close Unity
  6. Paste the backed up Library folder inside your project and replace everything when it asks
  7. Load your project again, and everything will be fixed, no errors, all the windows normal again, and the inspector has a scrool bar again!, everything is fixed.

Hope this helps someone that sees this in the future, this is my first reply I make on the forum, I had been very annoyed with this bug.

Are you by chance using any of the *Group classes in any of your own components? If you have mismatched begin and end calls i.e. with BeginFadeGroup or similar stuff like this might happen. Unity used to handle these kind of errors gracefully, so asset store packages may often have similar issues if they’re not maintained.

You can also try unexpanding the various components by clicking the little arrow on the top-left of each component, to pinpoint which one is causing issues.

I got exactly the same problem for a few days. And I have some pretty big components. But I can’t scroll down to fill up all the component fields because the inspector has this weird behavior.
I can’t make my game to work without it. I don’t know what to do

I have the same issue, I am also using 2019.4.16

Copy two files in Library directory
CurrentLayout-default.dwlt and CurrentMaximizeLayout.dwlt
from a unity project which works fine.

This solved the problem for us.

Same happening to me

Looks like unity at each new version keep getting dumber and dumber

Go to the corner and resize the whole unity window. Sometimes the re adjustment snaps it back into place.