Unity white screen, is there really no solution?

I’m on a fresh install of Unity, never opened it on this machine before. As soon as it opens, I get a white screen, with nothing showing in the program. I tried searching the forums here and elsewhere with no real answers. I’ve tried rebooting, reinstalling, deleting all the config files and Appdata files.

Would love to build something on Unity, but… this is discouraging? Any ideas?


  • Windows 10
  • i7, 32gb ram, gtx 980
  • Unity: 2017.2.0f3 (64 bit)


The file menu still works, but I can’t get anything to show in the main window.

Dont know if you figured it out yet, but what I did to fix it is…
-Open Unity.exe properties
-Go to Compatiobility mode
-Clicked “Change highDPI settings” button
-Checked the box “Override high DPI Scaling behavior.Scalled performed by”

Open Unity and everythings fixed

fix for me was: right click on the desktop and select ‘nvidia control panel’ then on the left side select Manage 3D settings → then in the main window under ‘select a program to customize’ select unity 3d, if its not there then click ADD and add untiy, Under 'Select the preferred graphics processor for this program-> select Integrated graphics… then start unity again…
This did it for me

For anyone else having this issue. What solved it for me was disabling NVIDIA instant replay on the desktop. For some reason Unity just doesn’t like it.

Had to be some software on my machine conflicting with Unity. I closed as many applications as I could that were related to window, display, fps, monitoring, gaming, recording, etc… and eventually it opened. For anyone else who lands here, start with that.

try to change the layout from windwos > layout

For anyone landing here from google having this problem:
make sure that your antivirus doesn’t block required installation batches during Unity installation from the hub.