Unity won't animate Maya Model

The other day, for a test project, I made a very basic blockman made of spheres and cylinders. I didn’t really do any modelling or editing to the model. Then I rigged it with a similarly basic skeleton to a rigid bind and made a running animation.

Then I imported it into Unity. I went to the Character Import Settings and set the animation from 1 - 25 frames, Default Wrap Mode, with a Loop. However, no matter what I do, not only can I not access the animation settings of that animation take, but the animation won’t play at all. I’ve tried everything, but the animation just won’t play. I tried both FBX and MA formats. Nothing. I’ve had this problem with other models as well lately and I’m starting to think Unity might be the problem as opposed to Maya since this test character was intentionally basic enough that no real edits or effects were made to it, sans binding.

Please help. This has become a major problem!

You can’t use rigid bind in maya for unity, or any game engine for that matter. Unity uses skin weights and needs a smooth skinned character using the smooth skin options in maya. Rigid bind is really a form of lattice, which you can’t use in unity.

If all you are doing is using rigid bind to “parent” simple shapes, then you can parent them to the joints instead and it will work in unity. If you need any form of deformation (a cylinder bending as an elbow etc) then you will need to use smooth bind and set the skin weights in maya.