Unity won't open MY project

Hello guys, i’m having a very weird issue here, Unity won’t open my own project, but opens a New Project…
Any idea on how i could fix that ? (I’m currently using Unity Hub 2.3.1, and my project is using Unity 2019.3.0f1)

I tried to restart my computer, disable my internet connexion but then Instead of having the Unity screen that loads the project (and lasts forever when it won’t open), even that window crashed, giving me the message on the Hub : “unity is already in list. you cannot locate the same version”

I tried to log out, delete the license file, log in, request a new license manually and renew the license. It successfully renewed the license, but didn’t fix the problem.

I tried to open a scene from the project folders, but instead of loading my project, it loads a complete empty scene, and even like an empty project, there are none of my assets in there and there’s even an error telling me that it’s trying to find Opvise (one of my assets) but can’t find it what the heck… check this out :

Please save me, i’m freaking out right now worrying that my project could be corrupted or something like that uh… (i did so many things since my last backup…)

Up : I even tried to update my project to the latest official version of Unity, it doesn’t even tries to update it, AGAIN and Again that logo showing freezing forever…