Unity Won't Start

I don't know what I did. I was using Unity on the weekend with no problems and today it won't start. I've tried restarting, reinstalling, Techtool, PRAM, safe starting and deleting all preferences (that I could find).

The only hints I have are
1.) I installed Final Cut Studio Upgrade last night
2.) I deleted or backed up a bunch of things to make space but I didn't delete anything important (that I knew was important)

I tried reauthorizing also.

Just to be clear, I start Unity, a few seconds go by and then I get the submit crash report (which I did). It goes no further than that. I did generate an Apple crash report if that is of any use.

Beyond the above I have no idea what else to try (short of doing a complete reinstall of the OS, which I'd rather not do as everything else seems to be working).

Any help would be appreciated.

Shawn

YES! Thats it! FCP Upgrade to 5.1 kills Mono. Same thing happened to me Yesterday.

Anyone know of a way around this issue?

Hi. I found a workaround.
At least both applications are functional now.
I did an archive and install from my os x disc. that brought unity back to life and preserved most of my preferences. But you may have to reinstall some other applications. Good luck.

Did you also run Software Update and get everything up to date?

Thanks for the work around.

After much archiving and installing I have come to the conclusion that all of the Final Cut Pro programs will kill Unity. I have done about 6 different complete archive and installs (each time trying different combinations of the Final Cut Pro Suite) and each time Unity dies.

Does anyone know if there is a specific component that I could remove to make everyone play together. I need Unity more than Final Cut Pro but I would prefer to have access to both (or all if you consider Final Cut Pro, Soundtrack Pro, Compressor, DVD Studio Pro and Motion 2 all cause the problem). Etiquette wise should I be bugging Unity or Apple?

Thoughts and suggestions appreciated.

Thanks

sorry i think you got me wrong. i did NOT install fcp again - just the pro app runtime, which creates one folder in your system and is required for aperture, dvdstudio and others. when you do an archive and install your applications folder will not be deleted.

you can use pacifist to extract the packages from the final cut studio installer.

When I did the archive and install, Motion, Compressor and Sound Track Pro stopped working. That's why I tried may different install combinations.

But the good news is, I gave it one last try and figured out a way to get everything working. If anyone needs the details, let me know. For me it seemed that every install disc except Soundtrack Pro, contained something that interupted Unity.

In any event, all my programs seem to be working again (Unity, Final Cut Pro Suite and the others that got confused by the re-install).

Thanks for your help, phoen.

Investigating into this issue revealed that removing the file:
/Library/QuickTime/LiveType.component

makes Unity launch again.

I installed final cut studio and had no problem at all with Unity. I didn't install LiveType or Motion (my computer doesn't meet the requirements), and it was probably LiveType that did it (seeing as how removing a livetype component seems to have fixed it).

I can't remove the LiveType.component file as I need it for FCS, a solution to getting Unity and FCS working together would be great.

You can replace the live type framework which is found here:
/System/Library/PrivateFrameworks/LiveType.framework/

with the attached live type framework. Which is an older version and apparently works fine with Final Cut 5.1.