Unity3D - Entering Play Mode is ridiculously slow!

I’ve run into a problem.

When trying to enter Play Mode from the scenes I’m working on, Unity takes minutes "Importing Assets" before it actually starts.
This is behavior I haven’t seen before and I don’t know what to do with it. Obviously, waiting for minutes to test a change in a scene is painful.

Any suggestions?

Am using Unity-2023-2.14f1 on Windows 10

Try to go to Edit > Project Settings > Editor and there, do
image

This normally removes any reloading of the scene and script assemblies, but might cause some inconsistencies in behavior - for example, static variable values are not reset. In most cases, if you code stuff right, it causes no problems.

If the “Importing assets” process remains, it’s probably some code in your script that manipulates assets somehow… hard to tell, could be some 3rd party plugin or your code that dirties them.