so i’m stuck trying to build a unity3d project with Unity 2017.4.39f1 for iOS with MacOS Catalina and Xcode 11.4. The error shown in Unity is as bellow:
For info i have cocoapods and git are installed in my system normally.
Here is the error that unity is showing when trying to build for iOS:
Error running CocoaPods. Please ensure you have at least version 1.0.0. You can install CocoaPods with the Ruby gem package manager: > sudo gem install -n /usr/local/bin cocoapods > pod setup 'pod --version' returned status: 1 output: /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.9.1/lib/cocoapods/executable.rb:118:in `block in which!': [31m[!] Unable to locate the executable `git`[0m (Pod::Informative) from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.9.1/lib/cocoapods/executable.rb:117:in `tap' from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.9.1/lib/cocoapods/executable.rb:117:in `which!' from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.9.1/lib/cocoapods/executable.rb:143:in `capture_command' from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.9.1/lib/cocoapods/command.rb:116:in `git_version' from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.9.1/lib/cocoapods/command.rb:130:in `verify_minimum_git_version!' from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.9.1/lib/cocoapods/command.rb:49:in `run' from /Library/Ruby/Gems/2.6.0/gems/cocoapods-1.9.1/bin/pod:55:in `<top (required)>' from /usr/local/bin/pod:23:in `load' from /usr/local/bin/pod:23:in `<main>' UnityEngine.Debug:LogError(Object) Google.Logger:Log(String, LogLevel) Google.IOSResolver:Log(String, Boolean, LogLevel) Google.IOSResolver:OnPostProcessInstallPods(BuildTarget, String) UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)