Unity5.1.2f crash every time when trying to open project screen

I updated my Unity from 5.0.0 to 5.1.2f today. And it keeps crashing every time when I try to open the project screen (the one I can choose to create a new project or open an existing one).

After several resinstallings in different paths, removing register keys, running as administrator, it still crashes. The only chance I’ve got to launch it successfully was after I uninstalled another Unity installed in another folder. But when I tried to create a new project, it crashed again before the project screen shown.

I’ve also tried to downgrade to 5.1.1, still no good.

I’ve checked the editor log, and it only says “Crash!!!” with no further information.

Can anyone help me with this? Thanks!

===========================

Here are the logs:

The one that failed to launch at the very beginning:

LICENSE SYSTEM [201586 23:52:42] No start/stop license dates set

LICENSE SYSTEM [201586 23:52:42] Next license update check is after 2015-08-07T12:46:12

Built from ‘5.1/release’ branch; Version is ‘5.1.2f1 (afd2369b692a) revision 11522614’; Using compiler version ‘160040219’

OS: ‘Windows 8.1 (6.3.9600) 64bit’ Language: ‘zh’ Physical Memory: 8135 MB

BatchMode: 0, IsHumanControllingUs: 1, StartBugReporterOnCrash: 1, Is64bit: 1, IsPro: 0

Initialize mono

Mono path[0] = ‘D:/Unity/Editor/Data/Managed’

Mono path[1] = ‘D:/Unity/Editor/Data/Mono/lib/mono/2.0’

Mono path[2] = ‘D:/Unity/Editor/Data/UnityScript’

Mono config path = ‘D:/Unity/Editor/Data/Mono/etc’

Using monoOptions --debugger-agent=transport=dt_socket,embedding=1,defer=y

Crash!!!

For us installing Unity 32 bits solve the problem, but the 64 bit version still crashes