Unity5 build issue, not showing texture.

Here’s some pictures to explain visually Unity build issue - Album on Imgur

im using a tilemap - in the editor, it shows perfectly, when i run the game in unity editor, it runs and shows perfectly

but then i build the game, and the grass tiles vanish, HOWEVER, they do actually exist, because in a different map, they still appear- its as if the specific layer gets deleted, or vanished, or masked- none of these are however the case! The layer seems to work, and was working fine before - and i have changed nothing about it since that build.

Does anyone know whats happening? Or can help me? Because i cant for the life of me figure it out, when everything else works without issue.

Edit 1 - also i would show the code- but there’s nothing to it, basically anyway, it uses a tilemap renderer, a tilemap collision 2d (which is used as trigger) the only code/script attached is entirely unrelated to showing anything - and theres no mask, nor mask interaction on the tile, the sorting layer is fine, too

Seems i can include pictures, just found that out, so here.


Edit: After a bunch of developing, tried another build, same Result.
Edit2: I still cant seem to fix this annoying bug? Has nobody else found this?

well i been making some builds since, suddenly after a bunch of work done over- created a build and the textures work - i do NOT know what fixed it, it seems like a bug, but atleast its resolved?