unity_csc file can not be found by Unity and is preventing scripts from loading

I was just trying to open up a project in Unity 2020.3.3 and suddenly I started to get the following error message:

When I attempted to go into the scripts, each script component had a warning saying that it could not load the script, as seen here:

I know that there is no issues with the project itself because my friend is also working on the game and he has no issues currently. So whatever is happening is entirely on my end.

On top of that, the issue has since spread to every other version of Unity that I have installed.

I’ve looked this up for a few hours now and haven’t found any solutions that have helped so far.
Here are the things I’ve tried so far:

  1. Restart computer
  2. Restart Unity
  3. Uninstall then reinstall Unity and Unity Hub
  4. Ensure that cmd is on my PATH so .bat files are recognized
  5. Ran the System File Checker and repaired corrupt files
  6. Played around with file permissions, but I could have missed something or done something wrong
  7. Uninstalled Unity Hub and Unity, then reinstalled Unity from the archives rather than Hub
  8. Purge everything I could find within my system of any reference to Unity and then redownload it
  9. I tried to follow the instructions given by adrisj7 but the csc.exe file in Roslyn was giving me gibberish when I would open it.

From what I could see Hub might’ve been the thing to cause these issues so I stopped trying to use it in the process of fixing this issue.

(Sorry for no spaces between things, I do not know how to format on Answers)

Bumping because it’s almost 6 months later and I am still having issues. I am able to use a spare laptop to continue projects but not having access to my desktop is annoying. Something I forgot to state in the original post is that this occurs no matter which version of Unity I download or any new project that I create, they all run into this issue.