UnityARCore + Android App Bundle + Split Binary issue

I built an Android app bundle from my Unity project containing ARCore package from the package manager with the Split Application Binary option enabled, The build succeeds, but I get an error while uploading the aab file to playstore. The error says UnityARCore asset has been entered in both the modules (base & UnityDataAssetPack).

Here is a screenshot of the same error while computing apk size from the bundle file.

Here is another screenshot showing the two registries in Android Studio

This does not happen if I remove ARCore from the project. But I need it.
Has anyone faced this issue? How do I remove the ARCore registry from the UnityDataAssetPack module?

Any help would be greatly appreciated. Thank you.

Until the editor gets a bug fix for this - our team was able to follow the process below to fix this @Raptcha911.

Using unity 2020.3.19f1 - using the checkbox to build app bundles and split application bundles creates an error when checking apk sizes and will not be accepted by the Google Play Store.

[BT:1.8.0] Error: Both modules ‘base’ and ‘UnityDataAssetPack’ contain asset entry ‘assets/bin/Data/UnitySubsystems/UnityARCore/UnitySubsystemsManifest.json’.

We got this workaround to work by using the Google Unity plugin at

Specific Packages:

  • com.google.android.appbundle-1.5.0.unitypackage

  • com.google.play.assetdelivery-1.5.0.unitypackage

Steps to make a build with base and assets separately:

  1. Imported them as custom packages
    through the asset menu

  2. Uncheck split application binary in
    Publishing Settings

  3. Then use the Google Menu:

    a. Android App Bundle -> Asset Delivery Settings - check Separate Base APK Asset

    b. Build Android App Bundle

Our app was crashing because of a folder missing so we followed this link to fix that:


To reflect the up-to-date change, we used


Also, we imported Unity - Manual: Unity Asset Bundle Browser tool.

This solved our problem.