UnityWebRequest not working junt in Android with unity 2018.3.x

I’m having this weird problem…

I have a game that uses UnityWebRequest to make some GET requests, and it works fine on unity editor and when compiled to ios.

But just on Android devices, this same requests doesn’t work with unity version 2018.3, just switch plataform and compile to ios and android, without change code and without platform dependent compilation (#if) on code

Already tested all 2018.3.x subversions.

I always get this enlightening exception: “unknown error”, sometimes too: “cannot resolve destination host”

it worked fine on Android till 2018.2.21, just stopping work when upgrade.

Does anyone knows if something changed to android on 2018.3.x?

Things I already tried/tested to solve without success:

  • Set/unset development build

  • Test on many different android devices: get same error

  • Set internet access to require

  • Set minimum API to 4.1, 5.0, 8.0, 9.0…

  • Set target API to 5.0, 8.0, 9.0…

  • Set scripting runtime to .NET 4.0

same issue as me ,i use www instead of unitywebrequest, that was worked for me.

I still have this issue on Unity 2019.4.2f1, didn’t have it as much on Unity 2018