unty wont work!

every time i try to open unity it says to hold alt to create a new project or open a new one, but they never work!!! i just got unity (free) and i open the island demo and it crashed, i tried to reopen it and it said: "fatal error! could not copy default resources! you might be out of disk space or your project folder has no write access permissions. you can open a new project folder by holding alt at startup." i did, and i made a new project, but it didn't work! i tried downloading the tutorials and opening level 1 and it didnt work either! please help me fix this problem so i can use unity, i havent used it at all and i want to make a FPS (first person shooter).

How about some more details? How doesn't it work? What do you do? What do you expect to happen? What happens? Does it crash? Does it show an error?...

If you launch Unity without holding any other button it will load the last project you were in, or the "Create new project/Open project" dialogue if this is the first time launching Unity. Inside Unity the "File->New Project/File->Open Project" will show the same dialogue.

If you launch Unity and hold the alt button - that same "Create new project/Open project" dialogue will appear before loading the last project you were in.

If Unity crashes when you try and create a new project - send a bug report.

BTW - I've seen this behaviour with idiots who used pirated versions of Unity. Just wanted to point that out in case you're one of them.

Is your machine out of space? Sorry that people are assuming you have the pirated version and that your question has been down voted.

a few steps that might help (Please note im assuming your on windows here as you have not specified what version you are using).

1: Check that you are the system administrator (I imagine that if you're able to install software then you must be)

2: Check that you have A: enough free hard drive space and B: Enough RAM

3: Make sure you have no virus or malware (if so remove)

4:Restart Machine

5: Uninstall and Reinstall unity

6: Without looking at it 1st hand I can only ASSUME this should fix it, its possible your version of unity is corrupt, perhaps download it all over again as the download may have finished but have been partially corrupted (though often this will cause an instant error and wont let you open it, let alone install).

I have no idea what your HOLD ALT problem is, I've never encountered this before.

Uninstall your current Unity software and download the new version, the default game is Angry Bots not Island Demo because that is the sample game that goes with the older versions of Unity.