Unwanted edge smoothing when models deforms from animation

I model is meant to have no smoothing groups at all; in 3D Studio Max, I erased all smoothing groups, and in Unity it doesn’t matter if in the model import settings, I choose (under Normal & Tangents) Import or Calulate with a Smoothing Angle of 0. The model looks good as long as I don’t deform it by rotating the bones by hand or animating it. Then, the normals get smoothed as evident in the following pictures.

First picture shows the model standing still, no animations. All is good, clean, sharp edges.

Second picture: Animated, suddenly the edges / vertices that are deformed (especially at the elbows and hips) are smoothed!

alt text
alt text

So, I found a solution. Unity by default smoothes vertices when they are deformed by bones, but it’s possible to set the blending to 1, 2 or 4 bones (4 being default and maximum). If set to 1 bone, no blending takes place.

Edit → Project Settings → Quality → Other → Blend Weights