Update() faster than 90 FPS when using VR

Hi folks, I’ve been integrating Unity with other hardware through plugins recently, including the Oculus Rift. However, some of my hardware (a robot) would love to receive updates faster than the seemingly locked 90Hz. I’ve tried using FixedUpdate() to circumvent this, but when Update() is called, it breaks the “rythm”. I’m aware we’re using Unity very unconventionally.

Our system is capable of running my very simple demo (just one object on the screen moving around) at upwards of 1000FPS without VR (confirmed with an external logging tool), but once the Rift starts rendering VR.WaitForGPU rears its ugly head and slows everything down to 90FPS.

Does anyone know how to disable VR.WaitForGPU or unlock the frame cap? Or is this a GPU related problem. We have a 7700K with a 1080 Ti, running Unity 2017.1.1f1 with vsync Off.

Thanks!

You should be able to do that with InvokeRepeating