Upgraded project from 6000.3 to 6000.4 just before and bunch of errors.

,

Library\PackageCache\com.unity.2d.psdimporter\Editor\PSDPlugin\PDNWrapper\PDNDecodeJob.cs(420,6): error CS0246: The type or namespace name 'BurstCompileAttribute' could not be found (are you missing a using directive or an assembly reference?)

What are problems?

Until yesterday at 6000.3, no problem project.

But at 6000.4.... what is this mess?

9866868--1422000--6000.4.png

looks like you need the burst package..
unity now also updates packages without so much as a mention of what its done, so, it could be that version is a mess of the 2d ..

Just downgraded to 6000.3 and got peace. I don't have time to debug or gathering info source... its unity's responsibility.

The solution was literally just to install the Burst package as bugfinders said. You've Unity this many years, you should know what these errors mean.


I didn't know because this is first time happened. When upgraded from 6000.0, .1, .2, .3, there was no error like this.