Upgrading 2020.1 HDRP project

Tried opening a 2020.1.8 project (copy of) with the beta and got a number of errors like:
Library\PackageCache\com.unity.render-pipelines.high-definition@10.0.0-preview.27\Runtime\ShaderLibrary\ShaderVariablesXR.cs(20,70): error CS0117: 'ShaderConfig' does not contain a definition for 'k_XRMaxViewsForCBuffer'

Should it work yet (2020.2.0b6.3269)?

10.x is not supposed to be used with 2020.1, see: https://docs.unity3d.com/Packages/com.unity.render-pipelines.high-definition@8.2/manual/System-Requirements.html

And I didn't use 10 so not sure why it is saying that, weird error or it expects 10 in 2020.2...


It does expects the 10 in 2020.2. The error is coming from the 10.x package, didn't you try to upgrade to 2020.2 then downgraded the project? If so, you need to manually downgrade to 8.x or 9.x when downgrading to 2020.1

I got the same kind of errors when trying to upgrade a project from 2020.1 to 2020.2. I also would like to upgrade to HDRP 10. How should I proceed then?

I'm currently using HDRP 8, maybe I should upgrade to 9 first?

EDIT: I think I found what was wrong. By updating to 2020.2, it did update HDRP but not HDRP config. So naturally it couldn't work and I didn't see that because preview packages were disabled in my package manager.

2 Likes

I guess when 10 is out of preview it will all work - having packages and Unity in preview is maybe asking for trouble because do you upgrade to HDRP 10, then Unity 2020.2 - that should all happen automatically after beta finished I hope

It did work after errors & restarting & redoing HDRP asset...

I worked fine for me after updating manually HDRP Config. Only the main HDRP package was automatically being updated.


It is because you added HDRP Config manually, you should not do that unless you have some specific use case, in general add only the HDRP package and let the dependency system pick the correct HDRP Config for you


I didn't add HDRP Config manually, I didn't even know it existed haha

1 Like


If you let HDRP Wizard configure the thing for HDRP+DXR, it used to make a local copy of HDRP config. This isn't needed anymore on current HDRP versions.

I just upgraded from 2020.2.b2 to b7 and this error comes up. My project is the Gawain digital human demo project which I'm using to test my code.

If anyone else comes across this, you need to go into package manager, select Packages: In Project and then upgrade the HDRP Config to the latest .

14 Likes

It now works fine to 2020.2 (non beta) for me and upgraded HDRP to latest automatically.
I think beta versions caused problems no longer present.

Yeah man this was really bad on Unitys part. I upgraded my project from 2020.1 to 2020.2 and boom 50 errors or so.
I had NO FREAKING IDEA how to fix it because the package manager said I had the latest HDRP 10.2 asset.
But as @keithsoulasa said for some stupid reason even if it says you have 10.2 in the Unity registry and you import the samples or whatever it doesn't matter because the part you have to go to get it working is the "In Project" part and there you will see you actually have 8.2 and then once you hit upgrade the errors should fix although in my case I had a few assets that were outdated causing a few conflict errors but all the 50 Unity errors are fixed.

3 Likes


Thank you for the resolve, mine was stuck with version 8.1 after upgrading to 2020.2.2f1

1 Like

@ Team: We just updated a HDRP 7.3.1 project to Unity 2020.3.3f1 with HDRP 10.4.0 getting the same error the OP reported initially. Upgrading the HDRP Config from 7.3.1 to 10.4.0 manually was required to migrate, basically repeating the entire project migration.

If there is no reason, than the HDRP Config should automatically match the targeted HDRP version. SRP and URP respectively, have not checked on that.


Hi @HanananaStudios ,

That is not expected behaviour. There was a fix for a similar issue in the HDRP 10.2.0 package: https://issuetracker.unity3d.com/product/unity/issues/guid/1269654/

It would be much appreciated if you could submit a bug report for this issue with reproduction steps and ideally a reproduction project attached so we can investigate this case.

I'll add to this thread make sure to commit to some VCS regularly. I accidentally upgraded a 2021 project to 2020 and could only fix HDRP by reverting to my last commit.

Try to change the version of your XR Plugin Management to 3.2.13.