Upgrading IAP Package from 3.X to 4.4.1 and samsung

Hi,
Due to the future possible issues with google billing library V4, we need to upgrade the iap package from 3.x to 4.4.1. Everything is ok for android and ios, but we are facing problem with samsung. We are currently not using UDP and its seems we need to use it. What is the easiest way to do it? Can I keep android and ios code as it and just adding samsung with udp?

What problem with Samsung? I’m using a Samsung phone here without issue. I’m targeting Google Play on the device.

Oh sorry.
My issue is with the samsung store. We release on Ios App store, on Google play store and Galaxy store (samsung:) )
Since the update the samsungstorelistener used in previous package is obselete.

Yes, you would need to use UDP in that case. I'm moving this thread to the UDP forum