URP Point light range doesn't increase light range?

I want to light up dark scene with character near the fireplace, but the ‘fire’ light has very short range. I could set the range to infinity and it still wouldn’t increase the range, only the intensity has effect. Intensity actually affects the range too but then my character becomes nearly orange from so much intensity… Any way to work around that?

This is just how lighting works in URP. In reality, lights don’t have a ‘range’ - instead the distance light travels is proportional to the intensity of the light source itself. The builtin pipeline used an unrealistic linear attenuation factor that allowed separate range and intensities for lights, but in the new pipelines the range factor is just to control the maximum distance a light can reach for performance reasons.

You can make your own lighting function in a custom shader. then you can make the fall off/attenuation whatever you want… but you might not want to get that deep into things.

or if its just for one scene… you could try scaling down your entire scene ( apart from the light ) so in effect everything is closer to the light.
or to put it a different way, by scaling your scene and moving things closer or further from the light… your scene will pickup either a larger or smaller range of the light’s fall-off curve.
but if its your whole game you want to adjust, scaling everything might not be ab option

This is a question I got myself into recently and while the possibility of creating your own Tonemapping solution can be good for cases where you got to fine-tune things, there’s a slightly easier solution if you’re okay at redefining certain visual aspect on your project if all you want is for light source to reach further than their default range in URP.


The solution I have found as manageable is to add an Overwrite of type “Shadows Midtones Highlights” to the Global (or scene specific) Volume used by URP while using the Neutral Tonemapping mode.

This allows you to modify the lighting curve of the Tonemapping to limit or extend the shadows, midtones and highlights (based on your need). It has its limits, but I did was able to extend the light radius of effect visible on screen by enabling and adjusting the “Shadows” slider to the right.


In my case, I set the Shadows to 2.97f - 2.89f - 2.90f (about 3/4 toward the right) and changing the Shadows Limits End value to 0.1f. In the case of my scene, this double smoothly the range at which point lights, in my scene, would illuminate while using an Intensity between 0.5f and 1f. The only downside to it was that I had to update my skybox colors to counter the changes in shadows as my night skies would get a bit too bright otherwise.