Using the “android.max_aspect” in the Android manifest

I’m trying to set a max aspect ratio of 4:3 for my Unity game for Android. I used the max aspect ratio setting found here in the documentation:

However, when I launch my app on a 16:9 device, my app is not rescaled to 4:3 as explained in the link (instead, nothing happens):

An app can declare the maximum aspect
ratio it is able to support. If the
app runs on a device (or a portion of
the screen) with a wider aspect ratio,
the system automatically letterboxes
the app, leaving portions of the
screen unused so the app can run at
its specified maximum aspect ratio.
Here’s my Android manifest:

Here’s my Android manifest:

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.unity3d.player" android:installLocation="preferExternal" android:versionCode="1" android:versionName="1.0">

<supports-screens android:smallScreens="true" android:normalScreens="true" android:largeScreens="true" android:xlargeScreens="true" android:anyDensity="true" />
<!-- Flurry Permissions -->
<!-- Required permission -->
<uses-permission android:name="com.android.vending.CHECK_LICENSE" />
<uses-permission android:name="android.permission.INTERNET" />
<uses-permission android:name="android.permission.WAKE_LOCK" />
<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />
<uses-permission android:name="android.permission.ACCESS_WIFI_STATE" />
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />

<application android:theme="@style/UnityThemeSelector" android:icon="@drawable/app_icon" android:label="@string/app_name" android:debuggable="true" android:name="io.fabric.unity.android.FabricApplication">
    <activity android:name="com.unity3d.player.UnityPlayerActivity" android:label="@string/app_name">
        <intent-filter>
            <action android:name="android.intent.action.MAIN" />
            <category android:name="android.intent.category.LAUNCHER" />
        </intent-filter>
        <meta-data android:name="unityplayer.UnityActivity" android:value="true" />
        <!-- The max aspect ratio setting -->
        <meta-data android:name="android.max_aspect" android:value="1.34" />
    </activity>

    <activity android:name="com.unity3d.plugin.downloader.UnityDownloaderActivity" />
    <service android:name="com.unity3d.plugin.downloader.UnityDownloaderService" />
    <receiver android:name="com.unity3d.plugin.downloader.UnityAlarmReceiver" />
</application>

Did you also set the “Supported Aspect Ratio” fields in the Player Settings for the project?

Try to use the <application android:resizeableActivity="false" or <application android:resizeableActivity="false" and check the result