using the first person controller, how do i stop it sliding

so I am using the first person controller from the standard assets and i have noticed that if I am moving full speed forwards then turn 180 degrees instantly, I still slide backwards for a short time. I’m not great at JavaScript and would appreciate any ideas on how to fix this?
thaks

The answer to your question is very simple all you need to do is uncheck ‘Enabled’ under sliding in the character motor script.